FusePowered

Problem testing ios IAPs

4 replies [Last post]
ratdoggames
User offline. Last seen 2 years 5 weeks ago. Offline
Joined: 15 Jun 2011

I have been attempting to create my first ios game with IAP's for some time now and it would appear that the actual IAP's are the only thing holding me up from release.

I have created the IAP's in Itunes Connect (All currently say Waiting for Review), have a test account made and have looked at multiple tutorials on how to implement IAP.

At this moment the problem I am having is that none of my IAP are appearing to be tested.

When I initially open the app I am prompted to sign in ( so I sign in with the test account) then go to the IAP screen and nothing appears.

I have also attempted resetting the test device to see if that would help because it was recommended by someone in the past.

Anyone have added advice?? It would be greatly appreciated.

Replies

Naomi
User offline. Last seen 2 weeks 2 days ago. Offline
Joined: 6 Jun 2011

@ratdoggames, I'm not sure what you mean by "go to the IAP screen and nothing appears."

Do you have a set of code that responds to IAP transaction.state (such as "purchased", "restored", "cancelled", "failed", etc.) Without any code in your app that handles the response, I'd imagine nothing would happen...

If you have code that handles the transaction.state, I'm not sure why nothing happens after you sign in and initiate a transaction.

Naomi

ratdoggames
User offline. Last seen 2 years 5 weeks ago. Offline
Joined: 15 Jun 2011

My apologies on the confusion.

When I had stated go to the IAP screen I mean the section of our In Game Store where each of the IAP items reside. We currently have multiple consumable coin IAP that players are able to purchase. When the player enters the store all of the IAP's should appear to be purchased but at this moment all we get is a loading screen which eventually ends without any products appearing.

We do have code that responds to the above mentioned transaction states (purchased, etc) the problem we are having revolves around loading the products.

I am trying to test store.loadproducts so you have a better idea. To my understanding it should be returning an array of available products but I then have an empty array. Does this have to do with the IAP's still showing "Waiting for Review"?

Naomi
User offline. Last seen 2 weeks 2 days ago. Offline
Joined: 6 Jun 2011

@ratdoggames, I had my IAP in "Waiting for Review" state for months, and still able to test against iTC sandbox.

You might want to include lots of print statements to see how far your IAP code executes. You can also print a list of all products you have made available for purchase, which should help you greatly. If you are not sure how, I believe Ansca's In-App Purchase Sample Code includes the print statements that print out all of the valid products.

Also if you are unable to load any valid products (and that's why your IAP is failing), you may find this helpful: http://troybrant.net/blog/2010/01/invalid-product-ids/

Good luck!

Naomi

neil6
User offline. Last seen 1 year 45 weeks ago. Offline
Joined: 9 Feb 2012

Hi, i *think* i have the same issue, did you resolve it?

I am trying to port my IAP from a working Google Play set up to iOS

I load my App and navigate to the store, everything loads fine except my 5 products. If i change my product IDs i am greeted with an error (which is in place to report if no products are found).

What could be causing the images not to display? I have not created a test user account - could this be causing the issue?

All help appreciated! Thank you

Viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.