invalidProducts

11 replies [Last post]
ArchangelGabriel
User offline. Last seen 2 years 26 weeks ago. Offline
Joined: 12 Jan 2011

Hi,

I'm having trouble with the in-app purchases. When i load products, it always return me invalidProducts.

Do you have to "developer approve" on Itunesconnect for them to work?

Thanks

Replies

tempop
User offline. Last seen 1 year 14 weeks ago. Offline
Joined: 17 Sep 2010

You do not need to developer approve first. You will need to make sure they are "cleared for sale" though.

Here are some tips that I found helped me.

-Make sure you are building with a provisioning profile that uses the same UNIQUE appID as your inApp purchases
WORKS, profile - com.company.mygame and inAPP - com.company.mygame.item001
DOES NOT WORK, profile - com.company.* and inAPP - com.company.mygame.item001

-Sign out of your personal account from Settings->Store on the device, and wait until prompted within your app to sign in with your test user account.

-If you are building a brand new application, submit a binary to Apple and immediately reject it. I thought this was crazy at first, but after banging my head for a few hours, I read this and literally minutes later my products were showing up valid with no other changes.

http://troybrant.net/blog/2010/01/in-app-purchases-a-full-walkthrough/
"Step 5. - This detail is not mentioned anywhere in Apple’s documentation, but is a requirement nonetheless. You must submit a binary for your application in order to successfully test in-app purchases. Even if you aren’t 100% done, you need to submit a binary. However, you can immediately reject the binary so it won’t go through the review process.
This was the crucial step I missed that caused me hours of grief and frustration."

Hope this helps. Good Luck!

Lilarcor
User offline. Last seen 21 weeks 3 days ago. Offline
Joined: 24 Sep 2010

Just wondering if you worked out what the issue is.

I've created a number of In-App products for my iTunes Connect app in this exact format (and yes they are all checked for sale):

App Bundle ID: com.companyname.gamename

In-App Product 1: com.companyname.gamename.product1
In-App Product 1: com.companyname.gamename.product2
In-App Product 1: com.companyname.gamename.product3

When I run my app on my iPhone, i make a call to store.loadProducts passing it the following table:

local productList = {
"com.companyname.gamename.product1",
"com.companyname.gamename.product2",
"com.companyname.gamename.product3"
}

The connection to the App Store works fine, but each product ID in the productList is returned in the 'event.invalidProducts' server response.

Any ideas? It's driving me crazy and I can't do in-app testing until its working :S

Cheers
Cel.

ArchangelGabriel
User offline. Last seen 2 years 26 weeks ago. Offline
Joined: 12 Jan 2011

Yes thanks,

I tried Eric trick of uploading a binary and it worked. (Weird)

Thanks a lot guys

tempop
User offline. Last seen 1 year 14 weeks ago. Offline
Joined: 17 Sep 2010

Glad it helped. That one had me going crazy for hours.

Lilarcor
User offline. Last seen 21 weeks 3 days ago. Offline
Joined: 24 Sep 2010

Still no luck here :S

The only thing I can think of is that I'm still in the process of submitting my ABN and GST information in iTunes Connect.

Maybe Apple doesn't allow any In-App functionality (including testing), until all your contract information is submitted (?)

Did you guys have to complete your contract info before using in-app?

tempop
User offline. Last seen 1 year 14 weeks ago. Offline
Joined: 17 Sep 2010

Yea, I think you need to wait until your contract info goes through. Ansca mentioned that in the in-app release notes.

"make sure you submit you tax and banking information to Apple. In-app purchases will not work without this being cleared and you won't get any error messages telling you this is the problem."

Hopefully as soon as your contract clears things will start working for you. Good luck.

Lilarcor
User offline. Last seen 21 weeks 3 days ago. Offline
Joined: 24 Sep 2010

Ah right.. I must have missed that bit in the release notes, thanks for confirming that, I thought I was going mad.... many thanks, Cel.

BeyondtheTech
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 14 Apr 2010

Ok, it appears I'm stuck in the same boat. How long after you approve your own iAP item will it be ready to test with?

1. I believe my contract and banking information is working properly, as I've been selling on the App Store for two years already.
2. I added 4 iAP items and approved them about 18 hours prior to this posting. They are all "Cleared for Sale" and "Approved by Developer."
3. I uploaded a binary through the Application Loader late last night (about 7 hours ago), then rejected it on iTunes Connect.
4. I launch my app, and it doesn't show any products on the screen, and the Console says "Invalid product: com.beyondthetech..."

Any other ideas?

ArchangelGabriel
User offline. Last seen 2 years 26 weeks ago. Offline
Joined: 12 Jan 2011

Did you build the dev version with a provisioning profile that match this app (com.yourcompany.yourgame) ?

BeyondtheTech
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 14 Apr 2010

You beat me to my own reply. Looks like I skipped step #3 from http://troybrant.net/blog/2010/01/in-app-purchases-a-full-walkthrough/ and used my standard dev profile instead of building a specific dev profile just for that app.

It's working now, and iAP is so badass, this is absolutely great!

CORONA ROCKS.

Lilarcor
User offline. Last seen 21 weeks 3 days ago. Offline
Joined: 24 Sep 2010

Cool, I'll have to watch for that too. Now if only the slow Australian government would process my ABN request a bit faster so I can actually test iAP and release my game - grrrrrrr

Viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.